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Working With META tags 
META tags are HEAD elements that record information about the current page, such as the character 
encoding, author, copyright, and keywords. META tags can also be used to give information to the server, 
such as the expiration date, refresh interval, and PICS rating for the page. (PICS, the Platform for Internet 
Content Selection, provides a method for assigning ratings (like movie ratings) to Web pages.) Most 
importantly, META tags are used by search engines to allow them to more accurately list your site in their 
indexes.  

If you want to denote additional information about your HTML document, use the META tag and the 
following properties: 

Attribute Specifies whether the META tag contains descriptive information about the page (NAME) or 
HTTP header information (HTTP-EQUIV).  

Value Specifies the type of information being offered. Some values, such as description, keywords, and 
refresh, are already well defined (and have their own special Property inspectors in Dreamweaver), but you 
can specify practically any value (for example, creation date, document ID, level).  

Content Is the actual information. For example, if you specified level as the Value, Content might be 
beginner, intermediate, or advanced.  

What does a META tag look like? 
META tags are inserted at the top of your document, just after the <TITLE> tags. It follows the usual form 
of tags, ie <META name="something" content="something else"> but note that you don't have to have a 
</META> at the end of the tag, the way that you do with something like <BOLD> bold </BOLD>. 
However, make sure that each tag does not include any line breaks, since some search engines don't like this. 

There are basically two major META tags that you can use: 

<META name="keywords" content="a, list, of, keywords">  
Choose whatever keywords you think are appropriate, separated by commas. Remember to include 
synonyms. So, if you had a page on books, you might want to include keywords such as author, 
subjects, fiction, non-fiction and so on.  

Note: For a "robot friendly" Web page. The maximum number of characters we recommend for 
this Tag is 150 

<META name="description" content="a description of your page">  
Depending on the search engine, this will be displayed along with the title of your page in an index. 
"content" could be a word, sentence or even paragraph to describe your page. Keep this reasonably 
short, concise and to the point. Its a good idea to keep it relevant to your page and do not stray into 
other areas.  
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Note: Try separating each keyword with a comma and avoid multiple keywords. With some search 
engines this may be considered "word spamming". We would like to caution you regarding these 
multiple keywords. 

To View Elements in the Head Section of Document:  

Choose View > Head Content. For each element of the HEAD content, an icon appears at the top of the 
Document window.  

To Insert Elements Into the HEAD Section of a Document:  

1. Choose an item from the Insert > Head submenu.  

2. Enter options for the element in the dialog box that appears or in the Property inspector.  

To Edit Elements in the HEAD Section of Document:  

1. Click one of the icons in the HEAD section to select it.  

2. Set or modify the properties of the element in the Property inspector.  

Simple Example Tag 

<head> 
<title>Web Site Design</title> 
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"> 
<meta name="keywords" content="credit, webcourse,  design, online, course, college"> 
<meta name="description" content="A one credit course offered totally online by St. Louis 
Community College to introduce students to the design issues that take a web site from 
mediocre to marvelous in just 4 weeks."> 
</head> 

Refreshing or Redirecting Web Pages 
Use the Refresh element to specify that your page should refresh—by reloading the current page or going to 
a different one—automatically after a certain amount of time.  

Delay Is the time in seconds to wait before refreshing the page. To refresh the page immediately, enter 0 in 
this field.  

Action Specifies whether to go to a different URL or to refresh the current page. To go to a different URL, 
click the folder icon to browse to and select the page to load.  

To Insert a Page Refresh or Redirection 

Choose Insert> Head> Refresh 
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Working With Cascading Style Sheets (CSS) 
CSS gives both Web site developers and users more control over how pages are displayed. With CSS, 
designers and users can create style sheets that define how different elements, such as headers and links, 
appear. These style sheets can then be applied to any Web page.  

The term cascading derives from the fact that multiple style sheets can be applied to the same Web page. 
CSS was developed by the W3C. The specification is still evolving and is not fully supported by any current 
Web browsers.  

A style is a group of formatting attributes that controls the appearance of a range of text in a single 
document. A CSS style sheet can be used to control several documents at once and includes all of the styles 
for a document. The advantage of using a CSS style sheet over an HTML style is that in addition to being 
linked to multiple documents, when a CSS style is updated or changed, the formatting of all the documents 
that use that style sheet are automatically updated as well.  

CSS styles are identified by name or by HTML tag, allowing you to change an attribute of a style and see all 
text to which that style applies instantly reflect the change. CSS styles in HTML documents can control most 
of the traditional text formatting attributes such as font, size, and alignment. CSS styles can also specify 
unique HTML attributes such as positioning, special effects, and mouse rollovers.  

CSS style sheets reside in the HEAD area of a document and define a series of styles. CSS styles can define 
the formatting attributes for HTML tags, ranges of text identified by a CLASS attribute, or text that meets 
criteria conforming to the Cascading Style Sheets (CSS) specification.  

CSS style sheets work in 4.0 and later browsers. Internet Explorer 3.0 recognizes some CSS style sheets, but 
most earlier browsers ignore them.  

Creating a Style 
1. Choose Text > CSS Styles > Edit Style Sheet (or Ctrl + Shift + E) 
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2. Click on the New button 
 

 
Redefine HTML Tag styles  
Redefine the formatting for a particular tag, such as H1. When you create or change a CSS style for the H1 
tag, all text formatted with the H1 tag is immediately updated.  

To Redefine HTML Tag Styles 

1. Choose Window > CSS Styles 

2. In the CSS Styles palette, click the New Style button.  

3. Under Type, select Redefine HTML Tag. 

4. From the Tag list, select the HTML tag. 

 
5. Click OK. 
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6. In the Style definition dialog box, select the formatting settings for the new CSS style. 
 

 
7. Click OK. 

3 Common Style Definition Panels 
Type Panel 

Font Sets the font family (or series of families) for the style. Browsers display text in the first font in 
the series that is installed on the user's system. For compatibility with Internet Explorer 3.0, list a 
Windows font first.  

Size Defines the size of the text. You can choose a specific size by selecting the number and the unit 
of measurement, or you can choose a relative size.  

Style Specifies Normal, Italic, or Oblique as the font style. The default setting is Normal.  

Line Height Sets the height of the line on which the text is placed. Select Normal to have the line 
height for the font size calculated automatically, or enter an exact value and select a unit of 
measurement. This attribute is not supported by current browsers and causes problems in Internet 
Explorer 3.0 browsers.  

Decoration Adds an underline, overline, or line-through to text, or makes the text blink. The default 
setting for regular text is None. The default setting for links is Underline.  

Weight Applies a specific or relative amount of boldface to the font. Normal is equivalent to 400; 
Bold is equivalent to 700.  

Variant Lets you select a variation of the font, such as small caps. Dreamweaver does not display 
this attribute in the Document window.  

Case Capitalizes the first letter of each word in the selection or makes it all uppercase or lowercase. 
Dreamweaver does not display this attribute in the Document window.  

Color Defines the color of the text.  
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Box Panel  

Width and Height Determine the size of the element. Dreamweaver displays this attribute in the 
Document window only when it is applied to images or layers.  

Float Moves the element out of the page flow and places it at either the left or right page margin. 
Other elements wrap around the floating element as usual. Dreamweaver displays this attribute in 
the Document window only when it is applied to the IMG tag.  

Clear Defines the sides that do not allow layers. If a layer appears on the clear side, the element with 
the clear setting moves below it. Dreamweaver displays this attribute in the Document window only 
when it is applied to the IMG tag.  

Padding Defines the amount of space between the content of the element and its border (or its 
margin if there is no border). Dreamweaver does not display this attribute in the Document window.  

Margin Defines the amount of space between the border of the element (or the padding if there is 
no border) and any other element. Dreamweaver displays this attribute in the Document window 
only when it is applied to block-level elements (paragraphs, headings, lists, and so on).  

Block Panel  

Word Spacing Adds extra space between words. Word spacing may be affected by text justification. 
You can specify negative values, but the display depends on the browser. Dreamweaver does not 
display this attribute in the Document window.  

Letter Spacing Adds extra space between characters. You can specify negative values, but the 
display depends on the browser. Letter spacing overrides any extra space between letters caused by 
justification. Dreamweaver does not display this attribute in the Document window.  

Vertical Alignment Specifies the vertical alignment of the element, often in relation to its parent. 
Dreamweaver displays this attribute in the Document window only when it is applied to the IMG 
tag.  

Text Align Determines how text is aligned within the element.  

Text Indent Specifies how far the first line is indented. A negative value may be used to create an 
outdent, but the display depends on the browser. Dreamweaver displays this attribute in the 
Document window only when the tag is applied to block-level elements.  

Whitespace Determines how white space within the element is handled. Choose from three 
options: Normal collapses white space; Pre handles it as if the text were enclosed in PRE tags (that 
is, all white space, including spaces, tabs, and returns, is respected); Nowrap specifies that the text 
only wraps when a BR tag is encountered. Dreamweaver does not display this attribute in the 
Document window.  

Custom Style Class 

Creates a style that can be applied as a CLASS attribute to a range or block of text. 

To Make a Custom Style Class 

1. Choose Window > CSS Styles 
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2. In the CSS Styles palette, click the New Style button.  

3. Under Type, select Make a Custom Style (class). 

4. Enter a name. 
 
Custom CSS style names must begin with a period. If you don't enter the period yourself, 
Dreamweaver enters it for you.   
 

 
5. Click OK. 

6. Select the attributes you want to add. 

7. Click OK. 

8. Click Done. 

To Apply a Custom Style 

1. Choose Window > CSS Styles (or F7). 

2. Select the text to which you want to apply a CSS style.   
 
Place the insertion point in a paragraph to apply the style to the entire paragraph.  
 
To specify the exact tag to which the CSS style should be applied, select the tag with the tag selector 
at the bottom left of the Document window. You can also change the tag selection with the Apply 
To pop-up menu in the CSS Style palette.   
 
If you select a range of text within a single paragraph, the CSS style affects only the selected range.  

3. Click a style name in the CSS Style palette. 
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4. Your style will be updated. 

Note: Disable the Apply check box if you do not want the style automatically applied upon 
selection. 

To Edit, Duplicate or Delete a Custom Style 

1. Left click a style name in the CSS Style palette and choose your action from the shortcut menu. 
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Use the CSS Selector 
Defines the formatting for a particular combination of tags or for all tags that contain a specific ID attribute. 
This is useful when you want to modify a group of tags.  For instance you might want all of the different 
kinds of heading tags to be a certain color. Or you may use the CSS Selector style to apply styles to the 
various states of a link. 

To Define a Group of Tags 

1. As a shortcut, define a single tag out of your group (for example the h1 tag). 

2. Open the HTML inspector (F10) and locate your new style inside the <head> tag. 

3. Type the additional tags you want to modify using commas to separate them. 
 

 
4. Close the HTML Inspector 

To Apply Styles to the Various States of a Link. 

1. Choose Window > CSS Styles 

2. In the CSS Styles palette, click the New Style button.  

3. Under Type, select Use CSS Selector.  
 

 
4. From the Selector list, select a link state. 
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5. In the Style definition box select the formatting settings. 

6. Click OK. 

<A> tag state Description 
Active How the link appears in the HTML document. 

Hover State occurs when you place the pointer over the link and 
point changes to a hand shape. 

Link State occurs when you click a link to make it active. 

Visited State occurs when you click the link and the linked 
resource appears in the browser. 

Linked and Imported Style Sheets 
A CSS style sheet is an external text file containing styles and formatting specifications. If you edit an external 
CSS style sheet, all documents linked to that CSS style sheet are updated with the changes.  

To Create an External CSS Style Sheet:  

1. Choose Text > CSS Styles > Edit Style Sheet (or Ctrl + Shift + E).  

2. In the Edit Style Sheet dialog box, click Link.  

3. Enter a new file name (one that doesn't already exist at the specified location). The file name must 
end in the .css extension.   
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4. Select the Link to specify and create the tag used to attach the external CSS style sheet to the 

document. 

5. Click OK.  

The name of the external CSS style sheet appears with the identifier (link or import) in the list of styles in the 
Edit Style Sheet dialog box.  
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To Edit Your New Style Sheet 

1. In the Edit Style Sheet dialog box, select the name of the external style sheet and click Edit.   
 

 
 
The Edit Style Sheet dialog box appears for that style sheet.   

2. Click New to define styles in the external CSS style sheet.   
 

 
 

3. In the New Style dialog box, define the new style.   

4. Click Save when you have finished defining styles.  
 
Note: Your new style sheet will be saved in the same directory as your file. 

Import External Style Sheets  
Import brings the information in the external CSS style sheet file into the current document, while Link 
accesses and relays the information without transferring it.  
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To Link to a Style Sheet 

1. Choose Text > CSS Styles > Edit Style Sheet (or Ctrl + Shift + E).  

2. In the Edit Style Sheet dialog box, click Link.  

3. In the Link External Style Sheet dialog box, click the Browse button. 
 

 
4. Select the CSS style sheet and click on Select 

 

 
 
Note: Import brings the information in the external CSS style sheet file into the current document, 
while Link accesses and relays the information without transferring it.While both Import and Link 
call all styles in the external CSS style sheet into the current document, Link offers more features and 
works in more browsers. 
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About Conflicting Styles  
When you apply two or more CSS styles to the same text, the styles may conflict and produce unexpected 
results. Browsers apply style attributes according to the following rules:  

•  If two styles are applied to the same text, the browser displays all attributes of both styles unless 
specific attributes conflict. For example, one style may specify blue as the text color and the other 
style may specify red.   

•  If attributes from two styles applied to the same text conflict, the browser displays the attribute of 
the innermost style (the style closest to the text itself).  

•  If there is a direct conflict, the attributes from CSS styles (styles applied with the CLASS attribute) 
overrule attributes from HTML tag styles.   

In the example that follows, the style defined for H1 might specify the font, size, and color for all H1 
paragraphs, but the custom CSS style .Blue applied to this paragraph overrules the color setting in the H1 
style. The second custom CSS style .Red overrules .Blue because it is inside the .Blue style.  

<H1><SPAN CLASS="Blue">This paragraph is controlled by the
.Blue custom style and H1 HTML tag style.<SPAN
CLASS="Red">Except this sentence is controlled by the .Red
style.</SPAN> Now we're back to the .Blue
style.</SPAN></H1>

Layers and Positioning 
Layers provide Web page designers fine control over the exact pixel placement of elements. By putting page 
elements in layers, you can control which objects appear in front of each other and which ones are displaced 
or hidden. You can also use a timeline to move a layer or several layers simultaneously across a screen.  

To Create a Layer 

1 Place the insertion point in the Document window where you want to position the layer 

2 Choose Insert > Layer. 

To Insert an Image or Text into a Layer 

1. Mouse Click in the layer, and either start typing or choose Insert > Image 

Manipulating Layers 
As you work with your page layout, layers can be activated, selected, or resized. Activating layers lets you 
place content in them. Selecting layers lets you align, reposition, or resize them. Resizing layers lets you 
change the dimensions of a single layer or make two or more layers the same height and width.  

To Select a Layer 

1. Click the layer marker in the Upper left hand corner. 
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To Select Multiple Layers 

1. Shift-click inside or on the border of two or more layers. 

To Move a Layer 

1. Click the layer marker in the Upper left hand corner, hold down your left mouse button and drag it 
to a new position. 

 
To Resize a Layer 

1. Do one of the following:  

•  To resize by dragging, select the layer and drag any of its resize handles.  

•  To resize 1 pixel at a time, select the layer and press Control-arrow (Windows) or Option-
arrow (Macintosh).   

•  To resize by the grid snapping increment, press Shift-Control (Windows) or Option 
(Macintosh), while pressing an arrow key.  

•  In the Property inspector, type a value for width and height.  

Resizing a layer changes the width and height of the layer. It does not define how much of the layer's 
content is visible.   

To Resize Multiple Layers:  

1. In the Document window, select two or more layers.   

2. Do one of the following:  

•  Choose Modify > Layers and Hotspots> Make Same Width or Modify > Layers and 
Hotspots > Make Same Height.   

•  The first selected layers will conform to the width or height of the last selected layer 
(highlighted in black).  

•  In the Property inspector, under Multiple Layers, enter width and height values. The values 
are applied to all selected layers. 

Snapping Layers to a Grid  
Use the grid as a visual guide for positioning or resizing layers in the Document window. If snapping 
is enabled, layers are automatically positioned at the nearest snapping position when they are moved 
or resized. Snapping works regardless of whether the grid is visible.  
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To Display the Grid  

1. Choose View > Grid > Show.  

To Snap a Layer:  

1. Choose View > Grid > Snap To to turn snapping on (or to toggle it off).  

2. Select the layer and drag it; as you drag it, the layer jumps to the nearest snapping position. When 
released, the layer jumps to the nearest snapping position.  

To Change Grid and Snap Settings:  

1. Choose View > Grid > Settings to open the dialog box.  

2. Select the desired options.   

•  Visible Grid makes the grid visible. It works in tandem with the Show command (View > 
Grid > Show).   

•  Spacing defines the distance between grid markers. Enter a number and then choose pixels, 
inches, or centimeters from the Units pop-up menu. The minimum unit is 25 pixels.  

•  Color specifies the color of grid markers. The default color is light blue.   

•  Display specifies whether the grid displays as lines or as dots.  

•  Snapping turns snapping on and off. It works in tandem with the Snap To command 
(View > Grid > Snap To).   

•  Snap Every specifies a snapping unit. Enter a number of units in the Snap Every box and 
choose pixels, inches, or centimeters from the Units pop-up menu. The default value is 5 
pixels.  
 
To make layers snap to the Visible grid, the grid and snap pixel units must be the same. For 
example, if Spacing is set to 50 pixels, set Snap Every to 50 pixels.  

3. Click OK.   

To Align Two or More Layers:  

1. Select the layers.   

2. Choose Modify > Layers and Hotspots, then select an alignment option.   
 
For example, if you select Align Top, all of the layers move so that their top borders are in the same 
vertical position as the top border of the last selected layer (highlighted in black). 

Layer Preferences  
Use Layer preferences to define the default settings for new layers you create. Choose Edit > Preferences 
and then click Layers to change Layer preferences.  

•  Tag Determines the default tag used to define the layer. SPAN and DIV create CSS layers; LAYER 
and ILAYER create Netscape layers.  
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•  Visibility Determines whether layers are visible by default.  

•  Width and Height Set the default width and height of layers created by Insert > Layer.  

•  Background Color Specifies the default background color.  

•  Background Image Specifies a default background image.  

•  Nesting Makes a layer drawn within the boundaries of an existing layer a nested layer. Press Control 
(Windows) or Command (Macintosh) to temporarily change this setting while you're drawing a layer.  

•  Netscape 4 Compatibility Inserts JavaScript in the HEAD of a document and fixes how Netscape 
CSS layers resize in a browser. You can also add or remove the JavaScript, by choosing Commands 
> Add/Remove Netscape Resize Fix.  

Layer Properties  
Use the Property inspector to specify the name and location of a layer as well as to set other layer options. 
To see all of the following properties, click the expander arrow in the lower right corner of the Property 
inspector.  

 
Layer ID Allows you to specify a name to identify the layer in the Layer palette and for scripting. Enter a 
name in the unlabeled box on the left side of the Property inspector. Use only standard alphanumeric 
characters for a layer name. Do not use special characters such as spaces, hyphens, slashes, or periods.  

L and T Specify the position of the layer relative to the top left corner of the page or parent layer.  

W and H Specify the width and height of the layer. These values are overridden if the content of the layer 
exceeds the specified size.  

For CSS layers, the default values for location and size are in pixels (px). You can also specify the following 
units: pc (picas), pt (points), in (inches), mm (millimeters), cm (centimeters), or % (percentage of the parent's 
value). The abbreviations must follow the value without a space: for example, 3mm. The Overflow setting 
controls how CSS layers react when the content exceeds the layer's size.  

Z-Index Determines the z-index, or stacking order, of the layer. Higher-numbered layers appear above 
lower-numbered layers. Values can be positive or negative. It's easier to change the stacking order of layers 
using the Layer palette than to enter specific z-index values. See Changing the stacking order of layers.  

Vis Determines the initial display condition of the layer. Use a scripting language, such as JavaScript, to 
control the visibility property and dynamically display layer contents. Choose from the following options:  

•  Default does not specify a visibility property, but most browsers interpret this as Inherit.  

•  Inherit uses the visibility property of the layer's parent.   

•  Visible displays the layer contents, regardless of the parent's value.  
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•  Hidden hides the layer contents, regardless of the parent's value. Note that hidden layers created with 
LAYER and ILAYER still take up the same space as if they were visible.   

Bg Image Specifies a background image for the layer. Click the folder icon to browse to and select an image 
file, or type the path for the image in the text field.  

Bg Color Specifies a background color for the layer. Leave this option blank to specify a transparent 
background.  

Tag Determines whether the layer is a CSS layer or a Netscape layer. SPAN and DIV create CSS layers; 
LAYER and ILAYER create Netscape layers.  

Overflow (CSS layers only) determines what happens if the contents of a layer exceed its size. Choose from 
the following options:  

•  Visible increases the layer size so that all of the layer's contents are visible. The layer expands 
downward and to the right.  

•  Hidden maintains the layer's size and clips any content that doesn't fit. No scroll bars are provided.  

•  Scroll adds scroll bars to the layer regardless of whether the contents exceed the layer's size. 
Specifically providing scroll bars avoids confusion resulting from the appearance and disappearance 
of scroll bars in a dynamic environment. This option works only in browsers that support scroll bars.  

•  Auto makes scroll bars appear only when the layer's contents exceed its boundaries.  

Clip Defines the visible area of a layer. Specify values that represent the distance in pixels from the layer's 
boundaries. T (top) and L (left) settings are relative to the layer, not to the page.  

Use Left, Top or PageX, PageY (Netscape layers only) lets you position a layer in relation to its parent. The 
Left, Top option places the layer in relation to the top left corner of its parent. The PageX, PageY option 
places the layer in an absolute location relative to the top left corner of the page, regardless of the position of 
the parent layer.  

Layer Palette 
The Layer palette is a visual map of the layers in your 
document. Choose Window > Layers or press F11 to open the 
Layer palette. Layers are displayed as a stacked list of names; 
the first created layer is at the bottom of the list, and the most 
recently created layer is at the top of the list. Nested layers are 
displayed as names connected to parent layers. Click the 
expander arrow to show or hide nested layers.  

Use the Layer palette to prevent overlaps, to change the 
visibility of layers, to nest or stack layers, and to select one or 
more layers.  

 

To Change the Stacking Order of Layers in the Layer Palette:  

1. Choose Window > Layers to open the Layer palette.  
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2. Select and drag a layer up or down to the desired stacking order. You'll see a line appear as you move 
the layer. Release the mouse button when the placement line appears in the desired stacking order.   

Nesting Layers  
A nested layer is a layer created inside another layer. Use the Layer palette or the insertion, drag and drop, or 
drawing technique to create nested layers.  

You can use nesting to group layers together. A nested layer moves with its parent layer and inherits its 
visibility.  

To Create a Nested Layer  

1. Place the insertion point inside an existing layer and choose Insert > Layer.  
- or - 
Drag and drop a nested layer, drag the Layer button from the Object palette, then drop it inside an 
existing layer.  

Changing Layer Visibility  
While working on your document, you can show and hide layers to see how the page will appear under 
different conditions. Use the Layer palette to change the visibility of layers. Use the Layer preferences panel 
to set the default visibility for new layers. See Layer preferences.  

To Change Layer Visibility:  

1. Choose Window > Layers to open the Layer palette.  

•  In the row of the layer you're affecting, click in the eye-icon column until you set the desired 
visibility.  
 
-An open eye means the layer is visible.   
-A closed eye means the layer is invisible.   
-If there is no eye icon, the layer inherits visibility from its parent.   

To Change the Visibility of All Layers At Once:  

1. Choose Window > Layers to open the Layer palette.  

2. Click the header eye icon at the top of the column. 

Using Behaviors 
Behaviors allow the user's interaction with the page to change the page, or to cause certain tasks to be 
performed. A behavior is a combination of an event and an action. For example, when the user moves the 
mouse over an image (an event), the image might highlight (an action). An action consists of prewritten 
JavaScript code that performs specific tasks, such as opening a browser window, playing a sound, or 
stopping a Shockwave movie. Events are defined by browsers for each page element; for example, 
onMouseOver, onMouseOut, and onClick are events associated with links in most browsers, whereas 
onLoad is an event associated with images and the document body. Events are generated by browsers in 
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response to user actions; for example, when a visitor to your page moves the pointer over a link, the browser 
generates an onMouseOver event, and calls the JavaScript function (if any) that you've associated with that 
event. The events that you can use to trigger a given action vary from browser to browser.  

When attaching a behavior to a page element, you specify an action and the event that triggers it. Several 
actions can all be triggered by the same event, and you can specify the order in which the actions occur.  

Dreamweaver includes several behavior actions; additional actions can be found on the Dreamweaver Web 
site as well as on third-party developer sites. 

The Behavior Inspector  
Use the Behavior inspector to attach behaviors to objects 
and to modify parameters of previously attached behaviors. 
Behaviors are listed alphabetically by event. If there are 
several actions for the same event, the actions appear in the 
order in which they will execute.  

The selected tag appears at the top of the inspector.  

To open the Behavior inspector, choose Window > 
Behaviors or click the Behaviors button in the Launcher.  

Actions (+) Displays a list of actions that can occur. 
Choosing an action causes a parameters dialog box to 
appear.  

Delete (-) Removes a chosen action and associated event 
from the list in the Behavior inspector.  

Events For Specifies the browsers in which the current behavior should work. The selection you make from 
this menu determines which events appear in the Events pop-up menu.  

Up and down arrow buttons Move the selected action up or down in the behavior list. Actions are 
executed in the specified order.  

Events Displays all the events that can trigger the action. Different events appear depending on the object 
selected. If the expected events don't appear, make sure the correct object is selected. Use the tag selector at 
the bottom left of the Document window to select a tag.  

Note: Different browsers recognize different events for various objects. Choose the browsers in 
which you want the behavior to work from the Events For pop-up menu. Only the events 
recognized by the selected browsers appear on the Events pop-up menu.  

About Events  
The following list describes the events that can be linked to the actions listed in the Behavior inspector's 
Actions (+) pop-up menu. When a visitor to your Web page interacts with the page—for example, by 
clicking an image—the browser generates events; those events can be used to call JavaScript functions that 
cause an action to occur. (Events can also be generated without user interaction, such as when you set a page 
to automatically reload every 10 seconds.) Dreamweaver supplies many common actions that you can trigger 
using these events.  
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The list also specifies which browsers can generate each event. NS3 means Netscape Navigator 3.0; NS4 
means Netscape Navigator 4.0; IE3 means Internet Explorer 3.0; IE4  

onAbort (NS3, NS4, IE4) is generated when the user stops the browser from completely loading an 
image (for example, when the user clicks the browser's Stop button while an image is loading).  

onAfterUpdate (IE4) is generated when a bound data element on the page has finished updating 
the data source.  

onBeforeUpdate (IE4) is generated when a bound data element on the page has been changed and 
is about to lose focus (and is therefore about to update the data source).  

onBlur (NS3, NS4, IE3, IE4) is the opposite of onFocus. The onBlur event is generated when the 
specified element stops being the focus of user interaction. For example, when a user clicks outside a 
text field after clicking in the text field, the browser generates an onBlur event for the text field.  

onBounce (IE4) is generated when a marquee element's contents have reached the boundary of the 
marquee.  

onChange (NS3, NS4, IE3, IE4) is generated when the user changes a value on the page, such as 
when the user chooses an item from a menu, or when the user changes the value of a text field and 
then clicks elsewhere on the page.  

onClick (NS3, NS4, IE3, IE4) is generated when the user clicks the specified element, such as a link, 
button, or image map. (Clicking is defined as pressing and then releasing the mouse button while 
pointing to the element.)  

onDblClick (NS4, IE4) is generated when the user double-clicks the specified element. (Double-
clicking is defined as quickly pressing and releasing the mouse button while pointing to the element.)  

onError (NS3, NS4, IE4) is generated when a browser error occurs while a page or image is loading.  

onFinish (IE4) is generated when the contents of a marquee element have completed a loop.  

onFocus (NS3, NS4, IE3, IE4) is generated when the specified element becomes the focus of user 
interaction. For example, clicking in a text field of a form generates an onFocus event.  

onHelp (IE4) is generated when the user clicks the browser's Help button or chooses Help from a 
browser menu.  

onKeyDown (NS4, IE4) is generated as soon as the user presses any key. (The user does not have 
to release the key for this event to be generated.)  

onKeyPress (NS4, IE4) is generated when the user presses and releases any key; this event is like a 
combination of the onKeyDown and onKeyUp events.  

onKeyUp (NS4, IE4) is generated when the user releases a key after pressing it.  

onLoad (NS3, NS4, IE3, IE4) is generated when an image or page finishes loading.  

onMouseDown (NS4, IE4) is generated when the user presses the mouse button. (The user does 
not have to release the mouse button to generate this event.)  

onMouseMove (IE3, IE4) is generated when the user moves the mouse while pointing to the 
specified element. (That is, the pointer stays within the boundaries of the element.)  
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onMouseOut (NS3, NS4, IE4) is generated when the pointer moves off the specified element. (The 
specified element is usually a link.)  

onMouseOver (NS3, NS4, IE3, IE4) is generated when the mouse first moves to point to the 
specified element. (That is, when the pointer moves from not pointing to the element to pointing to 
the element.) The specified element for this event is usually a link.  

onMouseUp (NS4, IE4) is generated when a pressed mouse button is released.  

onMove (NS4) is generated when a window or frame moves.  

onReadyStateChange (IE4) is generated when the state of the specified element changes. Possible 
element states include uninitialized, loading, and complete.  

onReset (NS3, NS4, IE3, IE4) is generated when a form is reset to its default values.  

onResize (NS4, IE4) is generated when the user resizes the browser window or a frame.  

onRowEnter (IE4) is generated when the current record pointer of the bound data source has 
changed.  

onRowExit (IE4) is generated when the current record pointer of the bound data source is about to 
change.  

onScroll (IE4) is generated when the user scrolls up or down.  

onSelect (NS3, NS4, IE3, IE4) is generated when the user selects text in a text field.  

onStart (IE4) is generated when a marquee element's contents begin a loop.  

onSubmit (NS3, NS4, IE3, IE4) is generated when the user submits a form.  

onUnload (NS3, NS4, IE3, IE4) is generated when the user leaves the page.  

Attaching  a Behavior  
You can attach behaviors to the entire document (that is, to the BODY tag) or to links, images, form 
elements, or any of several other HTML elements. The browser determines which elements can accept 
behaviors. Internet Explorer 4.0, for example, has a much wider array of events for each element than 
Netscape Navigator 4.0 or any 3.0 browser.  

You can specify more than one action for each event. Actions occur in the order in which they're listed in the 
Actions column of the Behavior inspector. For information on changing the order of actions, see Changing a 
behavior.  

To Attach a Behavior:  

1. Select an object.   
 
To attach a behavior to the entire page, click the <body> tag in the tag selector at the bottom left of 
the Document window.  

2. Choose Window > Behaviors to open the Behavior inspector, or click the Behaviors button on the 
Launcher.   
 
The HTML tag of the selected object appears in the title bar of the Behavior inspector.   
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3. Click the plus (+) button and choose an action from the Actions pop-up menu. 
 
Actions that are dimmed in the menu can't be chosen, because they won't work in the current 
document. For example, the Play Timeline action is dimmed if the document has no timelines. If no 
events are available for the selected object, all actions are dimmed.  
 
A dialog box appears, displaying parameters and instructions for the action.  

4. Enter parameters for the action, and click OK.  
 
All actions provided in Dreamweaver work in 4.0 and later browsers. Some actions do not work in 
older browsers. See Using the behavior actions that ship with Dreamweaver.  

5. The default event to trigger the action appears in the Events column. If this is not the trigger event 
you want, choose another event from the Events pop-up menu.  
 
Different events appear in the Events pop-up menu depending on the selected object and on the 
browsers specified in the Events For pop-up menu. Events may be dimmed if the relevant objects 
do not yet exist on the page or if the selected object cannot receive events. If the expected events 
don't appear, make sure the correct object is selected, or change the target browsers in the Events 
For pop-up menu.  
 
If you're attaching a behavior to an image, some events (such as onMouseOver) appear in 
parentheses. These events are available only for links. When you choose one of them, Dreamweaver 
wraps an A tag around the image to define a dummy link. The dummy link is represented by a 
number sign (#) in the Property inspector's Link box. You can change the link value if you want to 
turn it into a real link to another page, but if you delete the number sign without replacing it with 
another link, you will remove the behavior. 

To Change a Behavior:  

1. Select an object with a behavior attached.  

2. Choose Window > Behaviors to open the Behavior inspector.  
 
Behaviors appear in the inspector alphabetically by event. If there are several actions for the same 
event, the actions appear in the order in which they will execute.   

3. Choose from the following options:  

•  To edit an action, double-click the behavior name, or select it and press Enter (Windows) 
or Return (Macintosh); then change parameters in the dialog box and click OK.  

•  To change the order of actions for a given event, select the behavior and click the up or 
down arrow button.  

•  To delete a behavior, select it and click the minus (-) button or press Delete. 
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Downloading and Installing Third-Party Behaviors  
One of the most useful features of Dreamweaver is its extensibility—that is, it offers users who are proficient 
in JavaScript the opportunity to write their own objects, behaviors, commands, and property inspectors. 
Many of these users have chosen to share their development efforts with others by submitting files to the 
Dreamweaver Web site. To download these extensibility files, open the Behavior inspector and choose Get 
More Behaviors from the Actions (+) pop-up menu.  

To Install a Downloaded Third-Party Behavior:  

1. Extract the behavior files from the downloaded archive with a file-decompression tool.  

2. Drag the extracted files to the Configuration/Behaviors/Actions folder in the Dreamweaver 
application folder.  

3. Relaunch Dreamweaver. 

Creating a Rollover  
A rollover is an image that changes when the pointer moves across it. A rollover actually consists of two 
images: the primary image (the image displayed when the page first loads) and the rollover image (the image 
that appears when the pointer moves over the primary image). When you create a rollover, both images must 
be the same size; if the images are not the same size, Dreamweaver automatically resizes the second image to 
match the properties of the first image.  

To Create a Rollover:  

1. In the Document window, place the insertion point where you want the rollover to appear.  

2. Insert the rollover by using one of these methods:  

•  Choose Window > Objects to open the Object palette, and click the Rollover button.  

•  Choose Insert > Rollover Image.  

3. In the dialog box that appears, enter the following information:  

•  Browse and select an image, or type the path and file name of the original image in the 
Original Image field.  

•  Browse and select a rollover image, or type the path and file name of the rollover image in 
the Rollover Image field.  

•  To create a link, browse and select a file, or replace the # in the Link field with a path and 
file name.   

•  To have Dreamweaver preload the images in the browser's cache, select the Preload Images 
option.  

4. Click OK.  

To Test a Rollover:  

1. Choose File > Preview in Browser.  
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2. In the browser, move the pointer over the primary image. The display should switch to the rollover 
image. 

Applying Behaviors To Images  
You can apply any available behavior to an image or image hotspot. When you apply a behavior to a hotspot, 
Dreamweaver inserts the HTML source code into the AREA tag. There are three behaviors that apply 
specifically to images: Preload Images, Swap Image, and Swap Image Restore.  

Preload Images Loads images that do not appear on the page right away (such as those that will be 
swapped in with timelines, behaviors, layers, or JavaScript) into the browser cache. This prevents delays 
caused by downloading when it is time for the images to appear.  

Swap Image Swaps one image for another by changing the SRC attribute of the IMG tag. Use this action to 
create button rollovers and other image effects (including swapping more than one image at a time). See 
Swap Image.  

Swap Image Restore Restores the last set of swapped images to their previous source files. This action is 
automatically added whenever you attach the Swap Image action to an object by default; you should never 
need to select it manually. See Swap Image Restore.  

Swap Image  
The Swap Image action swaps one image for another by changing the SRC attribute of the IMG tag. Use this 
action to create button rollovers and other image effects (including swapping more than one image at a time).  

Note: Because only the SRC attribute is affected by this action, you should swap in an image that has the 
same dimensions (height and width) as the original in order to avoid distortion.  

To Use the Swap Image Action:  

1. Choose Insert > Image or click the Image button on the Object palette to insert an image.  

2. In the Property inspector, enter a name for the image in the leftmost text field.  

•  The Swap Image action still works if you do not name your images; it names unnamed 
images automatically when you attach the behavior to an object. However, it is easier to 
distinguish images in the Swap Image dialog box if all of the images are named beforehand.   

3. Repeat steps 1 and 2 to insert additional images.  

4. Select an object (generally the image you're going to swap) and open the Behavior inspector.  

5. Click the plus (+) button and choose Swap Image from the Actions pop-up menu.  

6. From the Images list, select the image whose source you want to change.  

7. Click Browse to select the new image file, or enter the path and file name of the new image in the Set 
Source To field.  

8. Repeat steps 6 and 7 for any additional images you want to change.  

9. Select the Preload Images option to load the new images into the browser's cache when the page is 
loaded.  

•  This prevents delays caused by downloading when it is time for the images to appear.  
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10. Click OK.  

11. Check that the default event is the one you want.  

•  If it isn't, choose another event from the pop-up menu. If the events you want are not listed, 
change the target browser in the Events For pop-up menu. 

Creating Navigation Bars  
A navigation bar consists of an image, or a set of images, whose display changes based on the actions of a 
user.  

Before using the Insert Navigation Bar command, create a set of navigation bar images for the states of an 
image you want displayed.  

An image can have four states:  

Up: the image that appears when the page initially loads.  

Over: the image that appears when the pointer is rolled over an image.  

Down: the image that appears when an image is clicked.  

Down and Over: the image that appears when the pointer is rolled over the image after the image 
has been clicked.  

You can create a navigation bar, copy it to other pages in your site, and edit the page behaviors to show 
different states as pages are accessed.  

To Create a Navigation Bar:  

1. Choose Insert > Navigation Bar.  

2. In the Element Name field, type a name for the navigation bar element.   

•  Element names appear in the Nav Bar Elements list. You can use the up or down arrow button 
to arrange elements in the navigation bar.  

3. Select image state options (you must select an Up Image; other image states are optional):  

4. In the When Clicked, Go To URL field, select a location in which the file will open by doing one of 
the following:  

•  Select Main Window to open the file in the same window.  

•  Select a frame in which the file will open.  

5. Select image loading options:   

•  Preload Images downloads the images when the page loads. If this option isn't selected, there 
may be a delay when the user moves the pointer over the rollover image.  

•  Select Show "Down Image" Initially to display the selected element in its down state when 
the page is displayed. For example, when the home page loads, the home page button should be 
in its down state.   

6. Under Insert, select from these options:  
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•  To insert the navigation bars elements vertically or horizontally in the document, use the Insert 
pop-up menu.  

•  To insert the navigation bar elements in a table, select the Use Tables checkbox.  

7. Click the plus (+) button to add another element to the navigation bar, then follow steps 2 through 6 
to set the state for that element.   

8. Click OK. 

Using Templates 
A template is a document that you can use as the foundation for other documents. When you create a 
template, you can indicate which elements of a page should remain constant (noneditable) and which 
elements can be changed. For example, if you are publishing an online magazine, the masthead probably 
won't change, but the title and content of the feature story will change in every issue. To indicate the style 
and location of the feature story, you can use placeholder text and define it as an editable region. To add a 
new feature article, the writer just selects the placeholder text and types the article over it.  

You can modify a template even after you have used it to create documents. Then, when you update 
documents that use the template, the locked (noneditable) sections of those documents are updated to match 
the changes to the template.  

Creating Templates  
You can create a template from an existing HTML document and then modify it to suit your needs, or you 
can create a template from scratch, starting with a blank HTML document.  

Templates are automatically stored in the Templates folder in the local root folder for the site. If this folder 
does not already exist, Dreamweaver creates it when you save a new template.  

To Save an Existing Document as a Template:  

1. Choose File > Open and select a document.  

2. Choose File > Save as Template.   

3. In the dialog box that appears, select a site and enter a name for the template in the Save As box.  

4. Click Save.  

To Create a New, Blank Template:  

1. Choose Window > Templates.  

2. In the Template palette, Click the context menu button, then select New Template.   

3. While the template is still selected, enter a name for the template.   

To Edit a Template:  

1. Choose Window > Templates.   

2. In the Template palette, double-click the name of the template.  

3. Edit the template in the Document window.   
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Setting Template Page Properties  
Documents created from a template inherit the template's page properties, except for the page title. If a 
document uses a template, you can change the document's title, but any changes you make to its other page 
properties are ignored.  

You define a template's page properties using the Modify > Page Properties command. If you need to 
change a document's page properties after the template has been applied, you must modify the template's 
page properties and then update the pages that use the template. 

To Define the Template's Page Properties:  

1. Open the template and choose Modify > Page Properties.   

2. Specify the desired options for the page and click OK.   

Modifying Templates and Updating the Site  
When you make a change to a template, Dreamweaver prompts you to update the pages that use the 
template. You can also use the update commands to manually update the current page or the entire site. 
Applying the update commands is the same as reapplying the template.  

To Open The Template Used to Create the Current Document:  

1. Choose Modify > Templates > Open Attached Template.  

Now modify the content of the template as necessary. To modify the template's page properties, choose 
Modify > Page Properties. (Documents created from a template inherit the template's page properties, 
except for the page title.)  

To Update the Current Document to the Most Current Version of aTemplate:  

1. Choose Modify > Templates > Update Current Page.  

To Update the Entire Site or All Documents that Use a Particular Template:  

1. Choose Modify > Templates > Update Pages.   

2. In the Look In pop-up menu, do one of the following:  

•  Choose Entire Site, and then select the site name. This updates all pages in the selected site to 
their corresponding templates.  

•  Choose Files That Use, and then select the template name. This updates all pages in the current 
site that use the selected template.  

3. Make sure Templates is selected in the Update option.  

4. Click Start. 

Using Libraries 
Libraries contain page elements such as images, text, and other objects that you want to reuse or update 
frequently throughout your Web site. These elements are called library items.  
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When you place a library item in a document, Dreamweaver inserts a copy of the HTML source code into 
the file and creates a reference to the original, external item. The reference to the external library item makes 
it possible to update the content on an entire site all at once by changing the library item and then using the 
update commands in the Modify > Library submenu.  

Dreamweaver stores library items in a Library folder within the local root folder for each site. You can define 
a different library for each site. 

Creating a Library Item  
When you create a library item, you select a portion of a document's BODY section, and Dreamweaver 
converts the selected area into a library item.  

Library items can include any BODY element, including text, tables, forms, images, Java applets, plugins, and 
ActiveX elements. Dreamweaver stores only a reference to linked items such as images. The original file 
must remain at the specified location for the library item to work correctly.  

Library items can also contain behaviors, but there are special requirements for editing the behaviors in 
library items. Library items cannot contain timelines or style sheets, because the code for these elements is 
part of the HEAD section.  

To Create a Library Item:  

1. 1  Select a portion of a document to save as a library item.  

2. 2 Choose Window > Library and drag the selection into the Library palette.  

3. 3  Enter a name for the new library item. 

Adding a Library Item to a Page  
When you add a library item to a page, the actual content is inserted in the document along with a reference 
to the original item. After the content has been inserted, the original item does not have to be present for the 
content to be displayed.  

To Add a Library Item:  

1. Place the insertion point in the Document window.  

2. Choose Window > Library or click the Library button on the Launcher.  

3. Drag an item from the Library palette to the Document window, or select an item and click 
Insert.   
 
To insert the item's content without creating an instance of the item in the document, press 
Control (Windows) or Option (Macintosh) while dragging an item out of the Library palette.  

Making Changes to a Library Item  
Editing a library item changes the original item file. Dreamweaver lets you choose to update the edited item 
in all documents in the current site, rename items to break their connection with documents or templates, 
and delete items from a library.  

Note: The CSS Style palette, Timeline inspector, and Behavior inspector are unavailable when you 
are editing a library item, because library items can contain only BODY elements. Timeline and CSS 
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style sheet code is part of the HEAD section, and the Behavior inspector is unavailable because it 
inserts code into the HEAD as well as the BODY section. For instructions on editing behaviors, see 
Editing a behavior in a library item.  

To Edit a Library Item:  

1. Choose Window > Library or click Library on the Launcher.  

2. Select a library item and click the Open icon (the folder icon) at the bottom of the palette, or 
double-click the item.  

3. Edit the library item and then save your changes.  

4. In the dialog box that appears, choose whether to update the documents on the local site with 
the edited library item:  

•  Choose Update to update all documents in the local site with the edited library item.   

•  Choose Don't Update to avoid changing any documents until you use Modify > Library > 
Update Current Page or Update Pages.  

To Update Pages That Use an Edited Library Item:  

1. Choose Modify > Library > Update Pages.  

2. In the dialog box that appears, choose the files that you want to update.  

•  Choose Entire Site to update all documents on the specified site.  

•  Choose Files That Use to update all documents that use the specified library item.  

3. Click Start.  
 
The content of the library item is replaced in the specified documents.  

To Rename a Library Item:  

1. Select a library item in the Library palette.  

2. Click inside the item name.  

3. Enter a new name.  

4. When you click OK, Dreamweaver asks if you want to update files that use the item.   
 
If you click Yes, all documents that previously used the item will update their references to the 
new name.   
 
 If you click No, documents that have references to the item under its old name will not 
automatically update their references to the new name.   

To Delete a Library Item from a Library:  

1. Choose Window > Library or click the Library button on the Launcher.  

2. Select an item in the Library palette.  
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3. Click the trash icon or press Delete.  

Deleting a library item removes the item from the library, but doesn't change the content of any 
documents.  

Editing a Behavior in a Library Item  
When you create library items that contain elements with behaviors attached to them, Dreamweaver copies 
the element and its event handler (the attribute that specifies which event to look for and which action to call 
when the event occurs) to the library item file. Dreamweaver does not copy the associated JavaScript 
functions into the library item. Instead, Dreamweaver automatically inserts the functions into the HEAD 
section of the current document (if they do not already exist) when you add the library item to the document.  

The JavaScript functions are not stored with the library item because they are HEAD elements, and library 
items can only contain BODY elements. Thus the Behavior inspector is unavailable when you are editing a 
library item, because only half of the behavior code is available to inspect. To edit a behavior in a library item, 
you must first make the item editable and then re-create it after making changes.  

To Edit a Behavior in a Library Item:  

1. Open a document that contains the library item.  
 
 Note the name of the library item, as well as the exact tags it contains. You'll need this 
information in steps 8 and 9.  

2. Select the library item and click Detach from Original in the Property inspector.  

3. Select the element that has the behavior attached to it.  

4. Choose Window > Behaviors to open the Behavior inspector, and then double-click the action 
you want to change.  

5. In the dialog box that appears, make the necessary changes and click OK.  

6. Choose Window > Library to open the Library palette.  

7. Delete the original library item.  

8. In the Document window, select the elements that make up the library item.  
 
Be careful to select exactly the same elements that were in the original library item.  

9. In the Library palette, use the context menu to select Create Library Item, and give the new item 
the same name as the one you deleted in step 7.   
 
 Be sure to use exactly the same spelling and capitalization.  

10. To update the library item in your site pages, do one of the following  
 
 Choose Modify > Library > Update Pages.  
 
 Use the context menu, then select Update Pages.  
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11. In the Update Pages dialog box, in the Look in pop-up menu, select Files That Use.  
 
 The name of the library item you just created should appear in the adjacent pop-up menu.   

12. Select Update Library Items, and then click Start.  

13. Click Close to exit the Update Pages dialog box. 

Advanced Site Management 
Creating a Site Map 
Creating a Site will enable you to easily update files as well as use other features like templates and others 
easier. The site map is a visual display within Dreamweaver of all the files and folders that belong to one 
specific site or several sites that share some links, files, folders, templates, etc… Other than using the Site 
window for the regular maintenance operations, you can also use it to transfer files between a local and a 
remote folder 

How to create a new site?  

1. Create the directory that your site is going to be placed in (refer to notes on Dreamweaver 1) 

2. Select new from the Site menu 

 
3. Give the site a name, the name is not linked to anything else. 
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4. Locate the Local Root Folder by clicking on the folder icon to the right. 

 
5. After reaching the root of the site, click on Select. 

6. Click ok 

7. There are two main views for the sitemap: Folder structure and links structure as shown below. 
Please note that your folder structure might look different in accordance to your files, Site 
Navigation and folder structure.  
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8. To switch view of different sites you can select the site from the drop down list next to Site: 

 
 

View and edit files from the sitemap: 

You can use the sitemap to view and edit local and remote files. To view a file, follow this procedure: 

1. Navigate to find the file you wish to view/edit 

2. Double click on the file 

3. Make your changes to the file and save before you close it. 

4. Once the file is saved, all the links to other files, pictures, graphics,… will be automatically updated. 

5. If you modify a template, all the files that use that template will automatically be updated as well. 
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Changing a Link Sitewide  
In addition to having Dreamweaver update links automatically whenever you move or rename a file, you can 
manually change all links (including mailto, FTP, null, and script links) to point somewhere else. You can use 
this option at any time (for example, you might have the words "this month's movies" linked to 
/movies/july.html throughout your site, and on August 1 you must change those links to point to 
/movies/august.html), but it's particularly useful when you want to delete a file that other files link to.  

To Change a Link Sitewide:  

1. Select a file in the Local pane of the Site window.  

2. Choose Site > Change Link Sitewide.  

3. In the dialog box that appears, click the folder icon to browse to and select a file, or in the Into 
Links To field, type the path and file name of a new file to link to.  

4. Click OK.  

Dreamweaver updates any documents that link to the selected file, making them point to the new file, using 
the path format that exists in the document (for example, if the old path was document relative, the new 
path is also document relative).  

After a link is changed sitewide, the selected file becomes an orphan (that is, no files on your local drive point 
to it). You can safely delete it without breaking any links at your local site.  

Note: Remember that because all changes are occurring locally, you will need to manually delete the 
corresponding file on the remote site and put or check in any files in which links were changed before 
visitors to your site will be able to see the changes.  

To Change E-Mail, FTP, Null, Or Script Links Sitewide:  

1. Open the site map.  

2. Choose Site > Change Link Sitewide.  

3. In the Change Link Sitewide dialog box, enter the following information:  
 
 In the Change All Links To field, type the full name of the link you are changing.  
 
 In the Into Links To field, type the full name of the link you want to replace the link with.  

4. Click OK.  

For example, to update all the e-mail links that point to your old address, you might type 
mailto:juser@isp.com in the Change All Links To box, and type mailto:juser-interface@isp.com in the Into 
Links To box.  

Connecting to your remote folder on the host server: 
The remote site is the folder located on the hosting server whether it is on campus or off campus. Follow 
these steps to create a remote site: 

1. Make sure that you create a local site that will have the same structure and files as the remote site 
ahead of creating the remote one. 
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2. Select Define sites from the site menu 

3. Select the site you like to define a remote connection for. 

 
4. Click on Edit 

5. Choose Remote Info from the list on the left of the box 

 
6. Select from the Access drop down list the best choice that reflects your situation. 

a. FTP: if the folder you are trying to locate is not accessible through the network you are 
connected to.  



M U L T I M E D I A  I N S T R U C T I O N A L  D E V E L O P M E N T  C E N T E R  

40 

 
� Please define the FTP address in the FTP Host box. 

� If you are assigned a directory on the hosting server, type the address of the 
directory. In case you are not sure, leave it blank. 

� Type your username and password that you use to access the hosting server. 

7. Click OK 

8. After clicking on Done on the next screen you see, the Site will open up again without showing the 
remote site. 

9. To activate the remote connection, click on:  located on the following menu: 

  
10. The remote site will show on the left side of the Site. The Blue arrow will upload your local files to 

the remote site, while the green arrow will get files from the remote server. 
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Checking in and Checking Out Files on a Remote Server  
Use the Site window or the Site menu in the Document window to check in and check out files on a remote 
server.  

If you've checked out a file but have decided not to edit it (or have decided to discard the changes you've 
made), you can undo a check out, to make the file on the server available to other team members to check 
out.  

Note: If you select Site > Check In or Site > Check Out while the Document window is active, and if the 
current file is not part of the currently open site, Dreamweaver attempts to determine which of your locally 
defined sites the current file belongs to; if the current file belongs to only one local site, Dreamweaver opens 
that site and then performs the Check In or Check Out operation.  

To Check Out Files from a Remote Server:  

1. Choose the desired site from the current sites pop-up menu at the top of the Site window.  

2. Check out files using one of the following approaches:  
 
-Select one or more files and click the Check Out button at the top of the Site window.  
 
-Choose Check Out from the context menu or the Site menu.  

3. To download dependent files along with the selected files, click Yes at the prompt. To refrain 
from downloading dependent files, click No.  

To Check In Files to a Remote Server:  

1. Choose the desired site from the current sites pop-up menu at the top of the Site window.  

2. Select one or more checked-out or new files in the Local pane and do one of the following:  
 
 Click the Check In button at the top of the Site window.   
 
 Choose Check In from the context menu or the Site menu.  
 
 Files checked out by you are marked with a green check mark. If a file has a red check mark 
next to it, it's currently checked out by another user; don't check in such files.  
 
 A lock symbol next to a file indicates that the file is read-only (Windows) or locked (Macintosh).  
 
 New files have neither a check mark nor a lock symbol next to them.  

3. To upload dependent files along with the selected file, click Yes at the prompt. To refrain from 
uploading dependent files, click No. It's usually a good idea to upload dependent files when 
checking in a new file, but if the latest versions of the dependent files are already on the remote 
server, there's no need to upload them again.  
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To Undo a Check Out:  

Select the file and choose Site > Undo Check Out, or right-click (Windows) or Control-click (Macintosh) the 
file and choose Undo Check Out from the context menu. The local copy of the file becomes read-only, and 
any changes you've made to it are lost.  

Note: You can also check in and check out a file that is currently active in the Document window. In the 
Document window, choose Site > Check In or Site > Check Out. If you check out the currently active file, 
the currently open version of the file is overwritten by the new checked-out version. If you check in the 
currently active file, the file may be automatically saved before it's checked in, depending on the preference 
options you've set. 
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